DANTE Switch Konfiguration Cisco IOS / IOS-XE

  • DANTE Switch Konfiguration Cisco IOS / IOS-XE

    Veröffentlicht von T3CHNIKFR3AK auf 17. Juni 2024 um 12:36

    Da ich selbst Lange danach gesucht habe, möchte ich euch hier meine DANTE Konfiguration mitgeben. Vielleicht kann diese jemand in Zukunft wieder verwenden.

    Background:

    Ich gehe davon aus das Zentral ein Core Switch vorhanden ist, auf dem alle andere Switches angeschlossen sind.

    In meinem Beispiel sind folgende Switches Verbaut

    Core: Cisco C3850 24 Port SFP+

    Acess: Cisco C3650 24 und 48 Port PoE+ mit 2x SFP+ Uplinks

    DANTE läuft über das VLAN 121, dieses ist nicht mit dem Router logisch verbunden und bildet ein geschlossenes Netzwerk. Einige DANTE Kanäle sind im Multicast Konfiguriert.

    WICHTIG: Die Interfaces und das VLAN sind entsprechend dem Setup vor Ort anzupassen.

    Core Switch

    Als erstes setzen wir den Core Switch als IGMP Querier

    ip igmp snooping querier

    DANTE ist abhängig von QoS, dies konfigurieren wir als nächstes

    class-map match-all DANTE-Audio

    match dscp ef

    class-map match-all DANTE-PTP

    match dscp cs7

    class-map match-all DANTE-Reserved

    match dscp cs1

    class-map match-all DANTE

    !

    policy-map DANTE

    class DANTE-Reserved

    set cos 4

    class DANTE-Audio

    set cos 5

    class DANTE-PTP

    set cos 6

    !

    Damit haben wir die Grundlagen geschaffen auf dem Core. Nun müssen wir dem Switch noch auf den Interfaces mitteilen wo die Policy nun gelten soll. Bei LACP Trunks muss die Policy auf die Physischen Interfaces gelegt werden. Dabei zu beachten das dies auf allen geschieht.

    interface TenGigabitEthernet1/0/3

    switchport mode trunk

    channel-group 1 mode active

    service-policy input DANTE

    service-policy output DANTE

    Access Switch

    Auch beim Access Switch setzen wir IGMP, diesmal aber als Snooping. Entsprechend das VLAN anpassen.

    ip igmp snooping vlan 121 last-member-query-count 2

    ip igmp snooping vlan 121 last-member-query-interval 1000

    !

    Auch hier wieder QoS setzen.

    class-map match-all DANTE-Audio

    match dscp ef

    class-map match-all DANTE-PTP

    match dscp cs7

    class-map match-all DANTE-Reserved

    match dscp cs1

    class-map match-all DANTE

    !

    policy-map DANTE

    class DANTE-Reserved

    set cos 4

    class DANTE-Audio

    set cos 5

    class DANTE-PTP

    set cos 6

    !

    Hier ein Beispiel für einen Port auf dem DANTE Untagged laufen soll. Bei uns beispielsweise eine Stagebox.

    interface GigabitEthernet1/0/1

    switchport mode access

    switchport access vlan 121

    service-policy input DANTE

    service-policy output DANTE

    !

    Und der Uplink ist wieder identisch zum Core Switch.

    interface TenGigabitEthernet1/1/3

    switchport mode trunk

    channel-group 1 mode active

    service-policy input DANTE

    service-policy output DANTE

    daniel beantwortet vor 1 Monat 4 Mitglieder · 6 Antworten
  • 6 Antworten
  • Martin

    Administrator
    17. Juni 2024 um 12:47
    34510
    Coach

    Mega! Danke dir für die Arbeit…

  • hermannr

    Mitglied
    17. Juni 2024 um 13:17
    600

    Oh wow, Held des Monats oder des Jahres. Mich hat das ganze Thema schon häufiger Beschäftigt, und ein paar Schrauben hatte ich noch nicht gesetzt. Probiere es Mal aus. Nutzen zwar Huawei Cloud Switches, die sind aber extrem ähnlich.

  • daniel

    Mitglied
    19. Juni 2024 um 15:51
    720

    Falls hier jemand irgendwelche best practices für Ubiquiti netzwerke hat gerne her damit 😇

    • T3CHNIKFR3AK

      Mitglied
      19. Juni 2024 um 15:55
      6040

      Ich kann dir für die Edgeswitches am Freitag noch einen Auszug machen von laufenden bei mir. Die Unifi Serie unterstützt leider einige Konfigurationen wie DSCP/QoS geschichte nicht, darüber DANTE laufen zu lassen kann funktionieren, muss aber nicht.

      • T3CHNIKFR3AK

        Mitglied
        21. Juni 2024 um 8:24
        6040

        Wie Versprochen hier noch die Config für die Ubiquitti Edge Serie. Da ich diese nur als Access Switch im Einsatz habe, kann ich die IGMP Config für den Core nicht bauen.

        QoS DSCP Mapping

        classofservice trust ip-dscp

        classofservice ip-dscp-mapping 8 3

        classofservice ip-dscp-mapping 9 1

        classofservice ip-dscp-mapping 10 1

        classofservice ip-dscp-mapping 11 1

        classofservice ip-dscp-mapping 12 1

        classofservice ip-dscp-mapping 13 1

        classofservice ip-dscp-mapping 14 1

        classofservice ip-dscp-mapping 15 1

        classofservice ip-dscp-mapping 16 1

        classofservice ip-dscp-mapping 17 1

        classofservice ip-dscp-mapping 18 1

        classofservice ip-dscp-mapping 19 1

        classofservice ip-dscp-mapping 20 1

        classofservice ip-dscp-mapping 21 1

        classofservice ip-dscp-mapping 22 1

        classofservice ip-dscp-mapping 23 1

        classofservice ip-dscp-mapping 32 1

        classofservice ip-dscp-mapping 33 1

        classofservice ip-dscp-mapping 34 1

        classofservice ip-dscp-mapping 35 1

        classofservice ip-dscp-mapping 36 1

        classofservice ip-dscp-mapping 37 1

        classofservice ip-dscp-mapping 38 1

        classofservice ip-dscp-mapping 39 1

        classofservice ip-dscp-mapping 40 1

        classofservice ip-dscp-mapping 41 1

        classofservice ip-dscp-mapping 42 1

        classofservice ip-dscp-mapping 43 1

        classofservice ip-dscp-mapping 44 1

        classofservice ip-dscp-mapping 45 1

        classofservice ip-dscp-mapping 46 5

        classofservice ip-dscp-mapping 47 1

        classofservice ip-dscp-mapping 48 1

        classofservice ip-dscp-mapping 49 1

        classofservice ip-dscp-mapping 50 1

        classofservice ip-dscp-mapping 51 1

        classofservice ip-dscp-mapping 52 1

        classofservice ip-dscp-mapping 53 1

        classofservice ip-dscp-mapping 54 1

        classofservice ip-dscp-mapping 55 1

        classofservice ip-dscp-mapping 56 7

        classofservice ip-dscp-mapping 57 1

        classofservice ip-dscp-mapping 58 1

        classofservice ip-dscp-mapping 59 1

        classofservice ip-dscp-mapping 60 1

        classofservice ip-dscp-mapping 61 1

        classofservice ip-dscp-mapping 62 1

        classofservice ip-dscp-mapping 63 1

        IGMP Einschalten

        set igmp

        Port Konfiguration im Access Mode

        interface 0/2

        set igmp

        set igmp fast-leave

        vlan pvid 121

        vlan participation exclude 1-3,20,98-100,120,140,250-253,255

        vlan participation include 121

        exit

        Uplink Port

        interface 0/49

        description 'sw1-core.liffehall.net'

        set igmp

        set igmp fast-leave

        set igmp mrouter interface

        set igmp mrouter 121

        vlan participation include 2-3,20,98-100,120-121,140,250-253,255

        vlan tagging 2-3,20,98-100,120-121,140,250-253,255

        exit

        Vielleicht hilft dies auch noch jemanden.

        Grüsse

      • daniel

        Mitglied
        21. Juni 2024 um 8:50
        720

        Sehr cool. Ganz lieben Dank dir!

Zum Antworten anmelden.